Hardware and Software Requirements

Hardware and Software Requirements

Version v2.1

Last update:

Hardware Requirements

Actual hardware requirements will vary based on your data size, workload and features you choose to install.

Component Minimum Recommended
CPU 1.8 GHz (64-bit processor) or faster multi-core Dual-socket multi-core, 2.0 GHz (64-bit processors) or faster
Memory* 8 GB ≥ 64 GB
Storage* 20 GB ≥ 1 TB, RAID10 volumes for better I/O throughput.

SSD storage is recommended.

Network 1 Gigabit Ethernet adapter 10 Gigabit Ethernet adapter for inter-node communication

*Actual needs depend on data size. Consult our solution architects for an estimate of memory and storage needs.

Comments:

  • The TigerGraph system is optimized to take advantage of multiple cores.
  • Performance is optimal when the memory is large enough to store the full graph and to perform computations.
  • The platform works excellently as a single node.  For high availability or scaling, a multi-node configuration is possible.

Certified Operating Systems

The TigerGraph Software Suite is built on 64-bit Linux. It can run on a variety of

Linux 64-bit distributions. The software has been tested on the operating systems listed below.  When a range of versions is given, it has been tested on the two endpoints, oldest and newest. We continually evaluate the operating systems on the market and work to update our set of supported operating systems as needed.  The TigerGraph installer will install its own copies of Java JDK and

GCC

, accessible only to the TigerGraph user account, to avoid interfering with any other applications on the same server.

On-Premises hosting Java JDK version GCCversion (C/C++)
RedHat 6.5 to 6.9 (x64) Yes 1.8.0_141 4.8.2
RedHat 7.0 to 7.4 (x64) Yes 1.8.0_141 4.8.2
Centos 6.5 to 6.9 (x64) Yes 1.8.0_141 4.8.2
Centos 7.0 to 7.4 (x64) Yes 1.8.0_141 4.8.2
Ubuntu 14.04 LTS

Ubuntu 16.04 LTS

Ubuntu 18.04 LTS

(x64)

Yes 1.8.0_141 4.8.4
Debian 8 (jessie) Yes 1.8.0_141 4.8.4

Additionally, we offer Amazon Machine Images (AMI) to run on Amazon EC2. Please contact us regarding recommended configurations.

 

Prerequisite Software

Utilities

Before offline installation, the TigerGraph system needs a few basic software packages to be present.

  1. tar, to extract files from the offline package
  2. curl, an alternative way to send query request to TigerGraph
  3. crontab, a basic OS software module which TigerGraph relies on
  4. uuidgen, a tool to creates an universally unique identifier of the server
  5. ip, to configure the network
  6. ssh/sshd, to connect to the server
  7. more, a tool to display the License Agreement
  8. netstat, a basic OS tool to check the network status
  9. semanage, to manage SELinux context of ssh
  10. sshpass,
    if you intend to use password
    login method (P method) instead of ssh key login method (K method) to install the TigerGraph platform.

If they are not present, contact your system administrator to have them installed on your target system. For example, they can be installed with one of the following commands.

# Centos or RedHat:
sudo yum install tar curl cronie iproute util-linux-ng net-tools coreutils openssh-clients openssh-server sshpass policycoreutils-python#Ubuntu or Debian:
sudo apt install tar curl cron iproute util-linux uuid-runtime net-tools coreutils openssh-client openssh-server sshpass policycoreutils

NTP

If you are running TigerGraph on a multi-node cluster, you

must

install, configure and run the NTP (Network Time Protocol) daemon service. This service will synchronize system time among all cluster nodes.

Firewall

If you are running TigerGraph on a multi-node cluster, you


must

configure the iptables/firewall rules to make all tcp ports open among all cluster nodes.

Browser

In an on-premises installation, the system is fully functional without a web browser. To run the optional browser-based TigerGraph GraphStudio User Interface or Admin Portal, you an appropriate browser:

Browser

Chrome

Safari

Firefox

Opera

Supported version

54.0+

11.1+

59.0+

52.0+



.